Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Photovoltaik mit SolarLog
#1
Ich hab bei mir eine PV auf dem Dach und ein Solarlog in Betrieb. Vielleicht hat das ja auch noch jemand anderes?

Ich möchte eigentlich nur die Daten des SolarLogs vom Gekko auslesen lassen. Wieviel Strom wird gerade erzeugt, wieviel verbraucht usw.

Lieben Gruß Florian

Der Gekko Neuling.
Lieben Gruß. Florian
#2
Ich hab nach dieser Anleitung, die ich vom Gekko Support erhalten habe, alles eingestellt, aber leider stellt er keinen Verbindung her.

wenn ich eine Falsche IP Adresse eingebe, kommt sofort Verbindungsfehler.
Bei der richtigen IP Adresse, steht dort Verbinde. Das steht aber dort schon seit 3 Tagen. 
Als ob er weiß, er ist richtig, bekommt aber die Verbindung nicht zusammen.

Hab extra schon den Gekko und Solarlog direkt an die Fritz Box angeschlossen, damit ich keinen Umweg über einen weiteren Switch habe, aber ohne unterschied.
Dem Solarlog hab ich auch schon eine neue IP zugewiesen, aber auch ohne erfolg. 

in meinem Fall ist der Solarlog auf 192.168.178.11 und der Gekko auf 192.168.178.32

Bin inzwischen etwas ratlos.


Angehängte Dateien
.pdf   SunSpec_PV_Inverter_DE (1).pdf (Größe: 849,26 KB / Downloads: 36)
Lieben Gruß. Florian
#3
Hallo Florian,

kannst Du hier mal Deine betroffenen Screenshoots einstellen.
Mehr Augen sehen ja mehr als zwei. Vielleicht können wir anhand Deiner Eingaben und der Screenshoots einen Fehler finden den Du hoffentlich übersehen hast.

Hast Du Deine Anlage mal mittels PC und IP-Nummer angepingt? Wenn ja antwortet diese?
Viele Grüße

Francisco Santos

Alle sagten "das geht nicht"... Dann kam einer, der dass nicht wusste und hat es einfach gemacht...
#4
Dass werd ich morgen früh nach der arbeit machen.

Über den pc ist es absolut kein Problem.
Selbst vom Handy geht es. Lediglich die ip in den Browser und schon bin ich auf dem solarlog
Lieben Gruß. Florian
#5
so, wie gesagt hier jetzt der Screenshot.

Der Gekko hat die 192.168.178.32


Angehängte Dateien Thumbnail(s)
   
Lieben Gruß. Florian
#6
Hallo,

um direkt nicht in die Falle zu laufen.... Ist der Port 502 in Deinem Router freigegeben?
Viele Grüße

Francisco Santos

Alle sagten "das geht nicht"... Dann kam einer, der dass nicht wusste und hat es einfach gemacht...
#7
Ich habe dem gekko und dem Solarlog in der Fritzbox erlaubt selbsständig ports freizugeben.
Daran kanns nicht liegen.

Es scheint daran zu liegen, dass der Solar-log nicht den typischen sunspec nutzt.

Dank Herr Holzer vom gekko Support ist es jetzt zumindest über Umwege so weit drinnen, allerdings fehlt mir jetzt der modbus Treiber. Somit läuft der gekko gerade unter der testlizenz.

Er meldet sich am Montag nochmal bei mir und er schaut, ob er noch irgendwie was machen kann, weil die kleinste modbus Lizenz liegt bei 199€
Lieben Gruß. Florian
#8
Hallo, die Anleitung dazu würde mich auch interessieren - wir haben auch Solarlog und  einen Speicher installiert.
Weis aber nicht, wie ich das an den Gekko bekomme.
#9
Hallo Sprinter.

Du brauchst auf jedenfall auch den Modbus Treiber. zum Testen kannst du deinen Gekko auch im Setup Modus laufen lassen.

Du musst in der IO Konfiguration eine mit modbus Lan einstellen siehe bei den bildern.
Danach unter register die abzufragenden werte einstellen.

es müssen zwei logiken angelegt werden 

und danach noch zwei zähler.

danach kannst du die zwei zähler dementsprechend im energiemanagment auswählen unter system energie.

Ich hoffe auf den Bildern ist alles ersichtlich. falls nicht, einfach nochmals melden.

ich weiß nicht, ob das mit dem Hauszähler so 1:1 bei dir auch funktioniert. Wir haben das Messverfahren Power to heat vom Energieversorger. somit läuft unser Hauptstromzähler auch in den Minus Bereich. Dies ist bei uns Aber durch die Logik des Hausverbrauchs wieder ausgeglichen.


Angehängte Dateien Thumbnail(s)
                               
Lieben Gruß. Florian
#10
Vielen Dank für die ausführliche Anleitung - das geht also nicht ganz so einfach wie mir das der Elektriker gesagt hat.
Wenn der kostenpflichtige Treiber benötigt wird, lasse ich es wohl und lese es im Portal aus.

Trotzdem vielen Dank
#11
(14.09.2017, 21:06)Sprinter schrieb: Vielen Dank für die ausführliche Anleitung - das geht also nicht ganz so einfach wie mir das der Elektriker gesagt hat.
Wenn der kostenpflichtige Treiber benötigt wird, lasse ich es wohl und lese es im Portal aus.

Trotzdem vielen Dank

Mygekko kann das sunspec Protokoll Lesen.
Dort fangen die Werte allerdings erst bei 40000 an. (Wenn ich es noch richtig im Kopf habe) 
Da wäre es auch einfach zum einstellen.

Beim solarlog ist der Wert der momentanen Erzeugung aber auf 3502 somit kann er über das sunspec Protokoll keine Verbindung herstellen.

Aber ich muss sagen, es hat schon etwas, wenn man den energiefluss im vorbei gehen oder vom Sofa aus mit einem Blick sieht. 
Hab mir die Anzeige auf die Startseite gelegt.
Mit einem Blick, ja die Waschmaschine kann man einschalten, die PV liefert genug Strom. Das ist durch die farbige Darstellung auch praktisch für meine frau
Lieben Gruß. Florian
#12
Ich nehme den Thread hier auf, weil ich eigentlich das gleiche Problem wie der TE vor 4 Jahren habe. Nur habe ich einen SMA Wechselrichter, der eigentlich auch im Anleitungsdokument enthalten ist:

Adressbereich von Gekko und WR sind gleich. Sieht man im Screenshot der Fritzbox.

Gekko:

[Bild: 973506-1613489643.jpg]
SMA Wechselrichter:

[img=10x10][Bild: fdf2f9-1613489920.jpg][/img]

Router:

[Bild: a06a08-1613490001.jpg]

Ich verstehe nicht, woran es liegt, dass die beiden sich nicht verbinden.

Wenn ich wie oben geschrieben eine Lizenz für 199,-- € kaufen muss, laß ich das aber auch...

Hilft mir jemand? Wenn ich es hinkriege, beeinflußt das nämlich meine Wallbox-Entscheidung
#13
Hallo Oli,

versuche es mal mit der Slave Adresse 126, wie im Handbuch beschrieben ist die Slave immer 123 + Standard die 3.

SMA:
Modbus TCP/IP --> Modbusadresse 123 + 3

Grüße
Fabian
#14
Hey Fabian,

vielen Dank! Die Verbindung ist hergestellt, IM Gekko steht die 126 jetzt im Slave die Unit ID im SMA auf 3.

Woher hast Du diese Information? Im Dokument oben, war sie nicht.

Ich frage, weil die Darstellung im Gekko noch nicht mit dem SMA übereinstimmt. Ich kriege nicht hin, dass der Netzbezug sowie der Gesamtverbrauch richtig dargestellt werden.

Frage 1: Was meinst Du im SMA 123 + 3? Wie genau soll das eingegeben werden?

Frage zwei: Was muss im I/O Bereich eingestellt werden: Aktuell habe ich als Messtyp System Energie eingestellt

Aktuell wird der solare Ertrag als Zukauf as dem Netz und Gesamtverbrauch dargestellt - wie stelle ich das richtig?
In welchem Dokument wird das richtig beschrieben?

[Bild: 8a0fc7-1613563509.jpg]
#15
Hallo Oli,

ist im Handbuch vom SMA Wechselrichter so beschrieben:
3.5 Adressierung und Datenübertragung

3.5.1 Unit IDs

Die Unit ID ist eine übergeordnete Adressierungsart im Modbus-Protokoll. Die Unit IDs im SMA
Modbus-Profil sind im Bereich von 3 bis 123 frei konfigurierbar. Der voreingestellte Wert ist 3.
Die Unit ID im SunSpec Modbus-Profil für SMA Produkte ergibt sich aus der voreingestellten Unit ID
im SMA Modbus-Profil + 123. Der voreingestellte Wert für die Unit ID im SunSpec Modbus-Profil ist
somit 126.

Und auch im myGEKKO Handbuch Sunspec was du im Anhang findest ist das mit der 123 bei SMA vermerkt.

Bezüglich der anderen Themen solltest du dich eventuell mal im Support melden, könnte noch an den Konfigurationen im myGEKKO liegen.
Eventuell würden noch einige Screenshots von der IO Konfiguration und den hinterlegten Zählern.


Grüße
Fabian


Angehängte Dateien
.pdf   DE_Technisches_Handbuch_SunSpec_PV_Inverter.pdf (Größe: 240,87 KB / Downloads: 1)
#16
Der Support schaut sich das in den nächsten Tagen an.

Bin ganz aufgeregt (-;


Gehe zu:


Benutzer, die gerade dieses Thema anschauen:
1 Gast/Gäste