Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
M-Bus Energiezähler Parameter falsch?
#1
Hallo zusammen,

ich hab mal eine Frage, nach einem anderen Thema hier im Forum kam bei mir das Thema Energiezähler noch einmal aufs Papier.
Mein Elektriker hat den einfach irgendwann mal eingebunden und seit dem läuft der so mit.
Da ich aber irgendwann einmal festgestellt hab, dass das aktuell nicht interessiert und dort sowieso nur komische Zahlen stehen wollte ich mich der Sache nun einmal annehmen.

Schau euch mal meinen Gesamtzählerstand an und den Gesamtwert.
Dass das nicht stimmen kann nach zwei Jahren ist mit klar. Aber ich weiß nicht warum das so hoch ist.

Dieser Energiezähler hängt an meinem Haus, nicht an der Heizung. Dort ist ja ein Zweirichtungszähler verbaut wegen PV und E3DC.

Vielleicht wisst ihr ja anhand der Parameter warum die Werte so seltsam sind.

Mein aktueller Zählerstand ist übrigens 18278kWh

   

   
MfG
Sven
#2
Hi Sven,
welcher M-Bus-Zähler ist denn verbaut, zufällig der EM340 von Carlo Gavazzi? Dieser übermittelt die aktuelle Leistung [kW] und und den Verbrauch [kWh] direkt an den Gekko. Der Gekko übernimmt stur die Werte mittels des M-Bus-Protokolls von vordefinierten Registern. Hab mich recht intensiv mit dem Teil beschäftigt und am Ende kamen bei mir brauchbare Werte raus.

Gruß Nils
#3
Moin Nils,

das ist schlussendlich das Problem, ich habe einen EM340...

   

So wurde der bei mir eingebunden.
MfG
Sven
#4
okay. In erster Näherung würde ich die Parameter direkt am EM340 prüfen. Da gibt es 2 Modi (a und b) siehe Handbuch. Ich habe meinen so eingestellt, dass er den Netzbezug und die Einspeisung trennt (vermute das war Modi b). Dadurch zeigt der Gekko bei Einspeisung ein negatives Vorzeichen an. Leider passen die berechnete Energie kWh vom EM340 nicht, da die negative Einspeisung als positiver Netzbezug gewertet wird. 
Ich habe gerade kein Zugriff auf den Gekko versuche es aber mal in Worte zu fassen:

Ich nehme den Energiezähler (EM340) als Eingang in eine Logik (Leistung [kW]) und speichere das in einen Merker x. Diesen Merker x nehme ich als Eingang ein einen weiteren Energiezähler. Dann berechnet der Gekko die Energie [kWh] korrekt aus der Leistung. Negativ Werte, also Einspeisung, werden ignoriert.

Falls dich die Einspeisung auch interessiert, kann man in der zuvor erstellten Logik die Leistung mit -1 multiplizieren und auf einen weiteren Merker y speichern. Merker Y wird dann in einem 3. Energiezähler als Eingang definiert.

Über diese 3 Energiezähler konnte ich gut über mehrerer Tage den Fehler nachweisen. 
Bsp: 
Energiezähler EM340 : 7kwh (fehlerhafte Energie Tag 1 entspr. Netzbezug + Einspeisung)
Energiezähler Logik mit Leistung von Merker x: 5,5 kWh (Energie Netzbezug Tag 1)

Energiezähler Logik mit Leistung von Merker y: 1,5 kWh (Energie Einspeisung Tag 1)

Prüft man die Energie über Monate ergibt sich das gleiche Bild.

Was mich hier stört ist, dass ich einen zusätzlichen Energiezähler verschenke (hab aktuell keinen mehr frei) um die korrekte Energie zu berechnen. Aus meiner Sicht könnte das der Energiezähler-Baustein wo der EM340 über M-Bus als Eingang definiert wird direkt erledigen. Dazu müsste lediglich die Energie vom Gekko berechnet werden.

Habe ein Ticket bei Mygekko aufgemacht und die Thematik auch telefonisch besprochen. Hier gab es damals keine Bestrebungen eine Anpassung durchzuführen.
#5
ich schaue mir das gleich noch einmal an, ich hab die Betriebsrat schon umgestellt eben. allerdings habe ich nur einen wert, zumindest in der Anzeige. du siehst ja meine Bilder. dort sieht man, das sich ihn via M-Bus eingerichtet habe. das klappt ja auch alles. aber irgendwie stimmen die werte gar nicht.
wenn ich meinen Haupt Zähler nehme und Einspeisung und Bezug addiere stimmt das auch nicht mit dem Italiener überein.

Das Thema Umsetzung von sinnvollen Vorschlägen ist auch ein Thema für mich Smile Da findet man im Forum schon den ein oder anderen beitrag, aktuell auch zum Thema Heizung. Das sehe ich genauso
MfG
Sven
#6
sehr interessant ist hier auch folgendes:
(@Strabbit)

wenn man einen M-Buszähler löscht und einen neuen an gleicher Stelle anlegt wird der alte nicht vollständig gelöscht. Das scheint im Allgemeinen so eine wohlwollend ignorierte Art und Weise von myGekko zu sein. Wenn man etwas entfernt, dass man eben nur dem Anschein nach etwas entfernt.
Lösche ich also den M-Bus Zähler und lege an gleicher stelle einen neuen an, dann steht der ja zunächst mal auf blanko. Aber hey, die Trends sind ja noch da vom alten.?! Was macht das denn für einen Sinn. also geschwind einen neuen Zähler mit gleicher Adresse an anderer Stelle erzeugt. Keine Trends vorhanden. >Toll<

Irgend eine Philosophie bei myGekko verstehe ich da nicht recht. Ich hoffe, dass diese "einfach" zu bezeichnenden Fehler irgendwann mal ausgemerzt sind. Dafür ist das System viel zu teuer, als dass das von Qualität spricht.
MfG
Sven


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Shelly 3EM als Energiezähler burkhi 0 281 28.01.2024, 19:27
Letzter Beitrag: burkhi
  Ergebnis einer Logik im Energiezähler darstellen fisch 3 1.351 21.01.2024, 12:36
Letzter Beitrag: burkhi
Question Seneca S501 falsch angeschlossen. Marco 2 1.062 23.05.2023, 10:21
Letzter Beitrag: Marco

Gehe zu:


Benutzer, die gerade dieses Thema anschauen:
1 Gast/Gäste