Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
LaMetric
#1
Hallo,


ich wollte Gekko dazu nutzen gewissen Informationen mittels HTTP Push auf meiner LaMetric anzeigen zu lassen. Ich habe gestern etwas probiert und auch eine Anleitung von Rupert gefunden, bin aber dennoch gescheitert.
Kann mir jemand der sich besser auskennt mal unter die Arme greifen?
Mein Problem ist das ich nicht weis wie man diesen Befehl bei Gekko so konfiguriert das er funktioniert.


HIER ist die Anleitung der Smart-Uhr für push Notifications



$ curl -X POST -u "dev:527cf879e81f7e3417dcc1639d896e1c2183c905cbbfed8fc86b7918e1085d96" -H "Content-Type: application/json" -d " { \"model\": { \"frames\": [ { \"icon\":\"a2867\", \"text\":\"Hello\!\"} ] } }" https://192.168.1.54:4343/api/v2/device/notifications --insecure
#2
Hallo Strabbit,

so müsste der Befehl aussehen:

Typ: POST-Output
Request On: http://192.168.1.54:8080/api/v2/device/notifications
Request Off/Parameter: -u "dev:527cf879e81f7e3417dcc1639d896e1c2183c905cbbfed8fc86b7918e1085d96" -H "Content-Type: application/json" -d " { \"model\": { \"frames\": [ { \"icon\":\"a2867\", \"text\":\"Hello\!\"} ] } }"

Zum Testen empfehle ich die Applikation Postman zu verwenden, siehe hier:
https://www.getpostman.com/

Hinweis:
Die maximale Länge von Name + Request On + Request Off/Parameter darf in der Summe nicht über 250 Zeichen betragen. Pro Request beträgt die maximale Länge 127 Zeichen.
Somit leider nicht möglich den Post-Befehl zu senden, da der "Request Off/Parameter" die Summe von über 127 Zeichen überschreitet.

Eventuell direkt über IFTTT LeMetric ansteuern?
https://ifttt.com/search/query/lametric?tab=connections

Euer myGEKKO Team
Rupert Jud
#3
Servus rjud,

Ich habe versucht Postman zu verstehen, aber dafür bin ich dann wohl in die Materie nicht Tief genug eingedrungen.

Mit IFTTT geht es so einigermaßen. Was mich daran stört ist aber die Notwendigkeit eines zusätzlichen Dienstes um meine Idee zu realisieren.
Warum gibt es die Beschränkung der Zeichen?
#4
Guten Abend,

die Beschränkun der Zeichen würde mich aber auch mal interessieren. Ich bin gerade beinahe verzweifelt, da meine Eingaben immer wieder verschwinden, nachdem ich die HTTP Befehle eingegeben habe.
Meine Befehle sind 181 Zeichen lang, jeweils für On und Off. Gibt es dafür irgendeinen Workaround bzw. wird das durch ein Update evtl. erweitert?

Danke und Gruß
Sascha
#5
Hallo Sascha,

als Workaround kann ich Dir nur den LiveViewer anbieten. Damit hat es bei mir auch immer mit langen Eingaben funktioniert. Vorteil: Du kannst es mittels Copy&Paste reinkopieren und muss es nicht mühevoll abtippen.

Viele Grüße
Frank
#6
Hallo Thomas,

du hast doch eine nodered Instanz am laufen...
Sende doch einfach alle notwendigen Daten per HTTP an nodered und lass den eigentlichen Befehl dann über nodered ausführen.

Beispiel von einem Dimmer:
On:
http://nodered:1880/mygekko/light9?state=1
Off:
http://nodered:1880/mygekko/light9?state=0
Brightness:
http://nodered:1880/mygekko/light9?brightness=@VALUE@


(Man müsste auch beide gleichzeitig übertragen können per http://nodered:1880/mygekko/light9?state=1&brightness=@VALUE@)

In nodered kann ich dann die Daten von "state" sowie von "brightness" weiterverarbeiten.
Siehe Anhang. In dem "Switch"-Node kannst du dann per msg.payload.state oder msg.payload.brightness darauf zugreifen.

Grüße
Sascha


Angehängte Dateien Thumbnail(s)
   


Gehe zu:


Benutzer, die gerade dieses Thema anschauen:
1 Gast/Gäste