Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
HTTP GET 401 Unauthorized
#1
Question 
Hallo,

ich versuche gerade meine Pellet-Heizung (Windhager BioWin2) mit dem Gekko zu verbinden. Testweise erst einmal nur die Aussentemperatur.
Via Firefox geht das auch problemlos:

.png   gekko1.png (Größe: 11,76 KB / Downloads: 983)

Nachdem ich die URL ins Gekko eingegeben habe, bekomme ich jedoch eine 401 (falsche login Daten):
   
   
   

Hat schon jemand Erfahrungen beim HTTP Zugriff mit BasicAuth? Hat es schon bei jemandem funktioniert?
Für Tipps wäre ich sehr dankbar. Komme nämlich gerade nicht weiter...

Viele Grüße und Vielen Dank!
#2
Bin etwas weiter gekommen. Firefox benutzt wohl Digest zur Authentifizierung mit der Heizung. Kann es sein, dass das Gekko nur BasicAuth (also unverschlüsselt) kann?
#3
Hallo Etienne Fuchs,

Der myGEKKO Slide 2 kann beides, sprich Digest und Basic Authentication.

Kontrolliere mal folgendes:
- nur mit einem Gerät zuzugreifen, also Firefox, etc. zu schließen und die Werte nur mit dem myGEKKO abzufragen.
- wird die Seite über http oder https aufgerufen?

Euer myGEKKO Team
Rupert Jud
#4
Danke für die Rückmeldung.

An ein Rate-Limit oder eine Beschränkung gleichzeitiger Clients dachte ich auch schon.
Ich kann die API der Heizung jedoch zeitgleich mit dem Notebook und Smartphone benutzen.
Nur der myGekko streikt leider weiterhin.

Die Api läuft via HTTP auf Standardport 80.

Welchen Header setzt das Gekko denn beim Zugriff GET-Input (Digest)? Eventuell kann ich es zu debug Zwecken mal vom Notebook aus mit diesen Einstellungen versuchen.
Danach wäre wohl Wireshark dran....
#5
Wireshark brachte etwas Licht ins Dunkel...

myGekko -> Windhager: GET (Authorization: Basic dXNlcjp1c2Vy\r\n Credentials: user:user)
Windhager -> myGekko: 401 (WWW-Authenticate: Digest realm="RC7000", nonce="dojAO62VBQA=1ea926682fa41a63089a2cc221b295c8e5beefac", algorithm=MD5, qop="auth"\r\n)

Und das ganze von vorne. Obwohl die Heizung digest verlangt, versucht es mein Gekko mit basic in Endlosschleife...

Da intern ein *nix läuft stehen die Chancen gut, dass myGekko curl verwendet. Ohne zusätzliche Parameter kann man das gleiche beobeachten:
# curl http://user:user@192.168.12.65/api/1.0/d...15/0/115/0
Notebook-> Windhager: GET (Authorization: Basic dXNlcjp1c2Vy\r\n Credentials: user:user)
Windhager -> Notebook: 401 (WWW-Authenticate: Digest realm="RC7000", nonce="dojAO62VBQA=1ea926682fa41a63089a2cc221b295c8e5beefac", algorithm=MD5, qop="auth"\r\n)

Übergibt man curl den Parameter --anyauth, versucht curl ein GET ohne Auth, reagiert dann aber auf den 401 inkl. digest Header mit einer einwandfreien digest Auth.
# curl --anyauth http://user:user@192.168.12.65/api/1.0/d...15/0/115/0
Notebook-> Windhager: GET (ohne auth infos!)
Windhager -> Notebook: 401 (WWW-Authenticate: Digest realm="RC7000", nonce="dojAO62VBQA=1ea926682fa41a63089a2cc221b295c8e5beefac", algorithm=MD5, qop="auth"\r\n)
Notebook -> Windhager: GET (digest mit gehashtem Passwort / cnonce)
Windhager -> Notebook: 200 (JSON Daten! :-) )

Ich hoffe das myGekko Team ließt hier mit, wenn nicht versuche ich es demnöchst mit einer Support-Mail...
#6
Hallo Etienne Fuchs,

vielen Dank für die Info.

Überprüfe das Problem erneut mit der aktuellsten Beta, die Du hier findest.

Euer myGEKKO Team
Rupert Jud
#7
Vorher: V5301-2
Jetzt: V5372-01

Gleiches Verhalten, kein Digest Login möglich.

Kann übrigens auch mit diesem öffentlichen Test-Server überprüft werden.
https://jigsaw.w3.org/HTTP/ (siehe: Digest Authentication test)
#8
ok, vielen Dank für die Info. 
Habe ich notiert und wir werden die Digest Authentication nochmal prüfen.

Euer myGEKKO Team
Rupert Jud
#9
überprüfe das Problem erneut mit der aktuellsten Beta-Version, siehe hier.

Euer myGEKKO Team
Rupert Jud
#10
Vielen Dank für die Info! Damit klappt es auch mit den HTTP Zugriffen auf meine Heizanlage.

Dankeschön.


Gehe zu:


Benutzer, die gerade dieses Thema anschauen:
1 Gast/Gäste