Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[GELÖST] Pluggit automatisch regeln via Logik
#1
Information 
Hallo,

ich versuche eine Regelung für meine Belüftungsanlage (Pluggit P310) zu erstellen.

Ich hatte mir folgendes vorgestellt:

Wenn [Außenluft (gemessen in Pluggit)] > X °C Dann Pluggit auf Lüfterstufe 0 setzen.

Generell habe ich mir Programmierung und Logiken kein Problem, aber ich habe Probleme die Richtigen Werte/Sensoren zu finden um z.B. die Temperatur der Zuluft aus der Pluggit auszulesen.
Ich nehme diese mit Absicht, da die normale Außentemperatur über die Gekko immer etwas höher gemessen wird, da der Sensor bis mittags in der Sonne liegt.
Die Pluggit hingegen zieht ihre Luft immer schön aus einem schattigen Plätzchen Wink

Ich bräuchte also nur die Möglichkeit A) den Wert in der Logik unter zu bringen und B) die Lüfterstufe per Logik zu setzen.

Kann mir jemand helfen, wie ich diese Aktionen in eine Logik einbringen, also was ich da auswählen muss?

Grüße
Alkahna



EDIT: Aktuelle Lösung

Habe meine Lösung in einen Extra Thread verschoben, damit hier nicht zu viel wird.

Pluggit-Anlage automatisch steuern (Kein Sommer-Bypass)

Sobald ich die Außenluft über den Sensor der Pluggit (einströhmende Luft) messen kann werde ich auf den Wert wechseln, da die "normale" Außentemperatur aktuell über einen Sensor gemessen wird der morgend in praller Sonne hängt  Sad

(08.05.2018, 16:03)Hammalui schrieb: Du musst im Startfenster unter Einstellungen (Zahnrad) gehen. Dann auf Register Wetterstation. Im Register Temperatur gibt es das Feld "Aussentemperatur von". Dort "von Lüftungsanlage" auswählen. Dann wird allerdings auch im Startfenster die Außentemperatur von der Lüftungsanlage genommen.

Das ist leider keine optimale Lösung, da sonst tagsüber auf dem Display ja die ganze Zeit die Temperatur des Kellerraums in der die Anlage hängt angezeigt würde (da die Lüftung ja aus ist) .
Ich überleg in diese Richtung mal noch weiter.
  • myGEKKO Slide V4725-02
  • 1x RIO 16
  • Pluggit Avent P310
#2
Hallo Alkahna, diese Regelung habe ich bei mir schon umgesetzt.

Du musst im Startfenster unter Einstellungen (Zahnrad) gehen. Dann auf Register Wetterstation. Im Register Temperatur gibt es das Feld "Aussentemperatur von". Dort "von Lüftungsanlage" auswählen. Dann wird allerdings auch im Startfenster die Außentemperatur von der Lüftungsanlage genommen.

Wie schon beschrieben kannst du dann die Außentemperatur in die Logik einbringen.

Die Regelung der Lüftungsanlage selbst kannst du nur über Aktionen und Merker verwirklichen.

Bei mir ist allerdings das Problem, dass die Aktion ausgeführt wird, die Lüftung (von Pluggit) ausgeht, aber nach einer dreiviertel Stunde wieder an geht. Dann aber auf Stufe 3. Kannst dass ja mal bei dir probieren. Wenn es besser klappt, gerne mir mal Bescheid geben, damit ich mein Problem im Griff bekomme.

Schönen Gruß

Hammalui
Gruß Hammalui

EFH (BJ 2017) - MyGEKKO Slide 2 - 1 RIO37 plus 3 RIO16 - Raffstoren über SMI - Raumbus mit Einzelraumregelung - Lüftungsanlage von Pluggit - Wärmepumpe Buderus - MyGEKKO Node - Photovoltaik-Anlage 9,6 kWp plus Speicher - Erweiterung zur Garage zum Schalten von Licht und Tor (in Arbeit)
#3
Hallo Hammalui,

ich glaube, dass die Pluggit wieder angeht könnte am Automatikprogramm liegen.
Wenn ich mich recht erinnere läuft die Pluggit im Automatikmodus, wenn nun ein Befehl für eine andere Lüfterstufe kommt, wird dieser umgesetzt aber nach ca. 1 Stunde wieder zur Automatik zurückgewechselt.

Du müsstest deine Lüftungsanlage meiner Meinung nach auf manuelle Bedienung stellen und die gesamte Regelung im Gekko abbilden.
#4
Hallo Bluescreen, ich hatte gestern mit dem Gekko-Support und mit Pluggit telefoniert. Die Lüftungsanlage schaltet sich generell nach einer Stunde wieder ein. Dies kann man auch nicht mit Gekko umgehen. Egal ob Automatik oder Handbetrieb, Auto oder Manuell. Die Lüftungsanlage geht wieder an.

Gibt aktuell also nur 2 Möglichkeiten:
1. Sicherung rausmachen (oder Stecker ziehen), Gekko macht dann aber Alarm und die Anlage schaltet sich nicht automatisch ein. Also keine gute Idee.
2. Ich schalte über Aktionen die Lüftungsanlage erst in den Manuellen Betrieb, dann die Lüfterstufe auf Stufe 1 und in den Sommer-ByPass. Jetzt zieht er über den Abluft-Ventilator zwar die Warme Luft LANGSAM raus und der Zuluft-Ventilator ist aus - also geht die Luft nicht über den Wärmetauscher. Wenn alle Fenster geschlossen sind, entsteht zwar ein leichter Unterdruck im Haus und irgendwie kommt dann ein bisschen warme Luft rein, ich hoffe aber, dass sich die Räume dann nicht mehr so stark aufheizen.

Habe ich gestern erst umprogrammiert. Der Test läuft also noch.

Gruß Hammalui
Gruß Hammalui

EFH (BJ 2017) - MyGEKKO Slide 2 - 1 RIO37 plus 3 RIO16 - Raffstoren über SMI - Raumbus mit Einzelraumregelung - Lüftungsanlage von Pluggit - Wärmepumpe Buderus - MyGEKKO Node - Photovoltaik-Anlage 9,6 kWp plus Speicher - Erweiterung zur Garage zum Schalten von Licht und Tor (in Arbeit)
#5
Hallo Hammalui,

vielleicht könntest du das auch umgehen, indem du dir einen Merker setzt, welche Lüftungsstufe geschaltet werden soll.
Dann eine Aktion, welche diese Stufe an die Pluggit sendet, diese Aktion wiederum alle 30 oder 45 Minuten selbst wiederholen lassen oder eben jede Stunde, könnte vielleicht funktionieren.
Rupert hat mir dazu mal eine Antwort geschrieben um eine Aktion quasi in einer Endlosschleife mit einem eingestellten Zeitintervall immer wieder wiederholen zu lassen.

https://forum.my-gekko.com/showthread.ph...66#pid2066


Wäre einen Versuch wert, allerdings sollte man die Lüftungsanlage ja nicht unbedingt komplett abschalten...
#6
Klingt sehr interessant. Wie du schon geschrieben hast, ist es besser die Lüftungsanlage laufen zu lassen. Daher werde ich erstmal den By-Pass testen. Wenn die Hütte wieder zu warm wird, werde ich die Endlosschleife testen. Vielen Dank.
Gruß Hammalui

EFH (BJ 2017) - MyGEKKO Slide 2 - 1 RIO37 plus 3 RIO16 - Raffstoren über SMI - Raumbus mit Einzelraumregelung - Lüftungsanlage von Pluggit - Wärmepumpe Buderus - MyGEKKO Node - Photovoltaik-Anlage 9,6 kWp plus Speicher - Erweiterung zur Garage zum Schalten von Licht und Tor (in Arbeit)
#7
(08.05.2018, 16:03)Hammalui schrieb: Hallo Alkahna, diese Regelung habe ich bei mir schon umgesetzt.

Du musst im Startfenster unter Einstellungen (Zahnrad) gehen. Dann auf Register Wetterstation. Im Register Temperatur gibt es das Feld "Aussentemperatur von". Dort "von Lüftungsanlage" auswählen. Dann wird allerdings auch im Startfenster die Außentemperatur von der Lüftungsanlage genommen.

Wie schon beschrieben kannst du dann die Außentemperatur in die Logik einbringen.

Das ist clever  Wink 
Leider löst das mein Problem nur zu 50%, da ich die Anlage auch automatisch wieder starten will, wenn die [Außentemperatur] < [Innentemperatur] ist.
Aber immerhin schonmal ein Anfang  Shy 

(08.05.2018, 16:03)Hammalui schrieb: Bei mir ist allerdings das Problem, dass die Aktion ausgeführt wird, die Lüftung (von Pluggit) ausgeht, aber nach einer dreiviertel Stunde wieder an geht. Dann aber auf Stufe 3. Kannst dass ja mal bei dir probieren. Wenn es besser klappt, gerne mir mal Bescheid geben, damit ich mein Problem im Griff bekomme. 

Das Problem habe ich bereits gelöst  Big Grin 

Hierfür musst du mit der Pluggit iFlow Anwendung (Link für AP190/310/460; AD160) als Admin in die Einstellungen deiner Pluggit Anlage gehen.
Sofern keiner bei dir in der Anlage Passwörter geändert hat sollten diese Standard-Passwörter bei dir funktionieren:

Benutzer: *leer*
Installateur: 1234
Admin: DAH1234

Die Einstellungen findest du im Punkt "Einstellungen" -> "Ventilatorenstufen".
[Bild: pluggit-avent-ventilatorstufen.jpg]

Die Logik für Stufe 0 ist (zumindest meiner Meinung nach) folgende:
Setze Lüftung auf Stufe [AUTO SETBACK] nach [ARBEITSZYKLUS] Minuten. Ist ja nicht viel/besonders Kompliziert was man hier einstellen kann.

Hier kann man bestimmt einige "Quality of Life" Verbesserungen für die Lüftung vornehmen  Big Grin 


EDIT:

(09.05.2018, 09:33)Bluescreen schrieb: Wäre einen Versuch wert, allerdings sollte man die Lüftungsanlage ja nicht unbedingt komplett abschalten...

Das stimmt wohl, habe ich auch irgendwo gehört. Also scheint die Idee mit der "Endlosschleife" eine gute Alternative zu sein (alle 60 Min kurz auf 1 anschalten und dann direkt wieder auf 0)
Wobei hier ja fast der gleiche Effekt erzielt wird mit der Ausnahme, dass die Ventilatoren mal kurz anlaufen.

Weiß jemand warum genau man die Anlange nicht komplett abschalten soll??


Die Standard-Passwörter habe ich übrigend von folgender Seite: http://www.msxfaq.de/tools/prtg/prtg-pluggit.htm (also an dieser Stelle ein Danke an den Autor)

Dort habe ich auch ein Powershell-Script gefunden und für meine Zwecke etwas reduziert. Es war zum automatisieren loggen von Parametern gedacht.
Ich habe es so weit reduziert, dass ich mir einfach nur bestimmte Werte in der Powershell ausgeben lasse. Was ich damit anstelle weiß ich noch nicht, aber es landet erstmal im Ordner Pluggit mit allen wichtigen Infos zur Anlage selber.

Bei Interesse folgenden Code als Powershell-Script (Dateiendung .ps1) ausführen:

Code:
# Script: Pluggit Werte auslesen

# Code als .ps1 Datei speichern
# Ausführen via: PS C:\Users\Admin\Desktop> & '.\Pluggit-Script.ps1'

# WICHTIG: Es kann sein das dieser Befehl nötig ist, um das Script zu starten !!!!
# Vor Ausführung: Set-ExecutionPolicy Unrestricted

# WICHTIG: Änderung nach Ausführung wieder Rückgängig machen, zwecks Sicherheit !!!!
# Nach Ausführung: Set-ExecutionPolicy restricted

# Zur Einfacheren Bedienung kann folgender Befehl verwendet werden:
#     powershell.exe -executionpolicy Unrestricted
# Dies ruft eine neue Powershell-Session auf, in welcher die ExecutionPolicy angepasst wurde.
# Vorteil, diese Ausnahme gilt nur für diese laufende Session und nicht für alle laufende Sessions und
# muss daher beim Beenden der Session nicht wieder zurück gesetzt werden.


param( 
    # IP DER PLUGGIT HIER EINTRAGEN
    [string] $remoteHost = "192.168.X.X", 
    [int]$port = 502


# set-psdebug -strict   # enforce strict variable checking

function modbusread ([string]$remoteHost, [int]$port, [int]$startaddress,[int]$bytecount,[string]$targetformat,[string]$flipoption) {

    #write-host "prtg-pluggit: Prepare request" 
    [byte[]]$sendbuffer=00,110  # Transaction Identifier
    $sendbuffer+=00,00            #Protocol identifier
    $sendbuffer+=00,06            #Length
    $sendbuffer+=00                #Unit ID
    $sendbuffer+=03                #Function Read Holding Registers
    $sendbuffer+=[byte]([math]::Truncate(($startaddress -40001)/256)),([system.byte](($startaddress -40001)%256))        #Data of first register   40133-40001 = 132
    $sendbuffer+=00,($bytecount)
    #write-host "prtg-pluggit: Send request" 
    $tcpclient = new-object System.Net.Sockets.TcpClient($remoteHost, $port) 
    $netStream  = $tcpclient.GetStream() 
    $netStream.write($sendbuffer,0,$sendbuffer.length)
    start-sleep -milliseconds 50
    #write-host "prtg-pluggit: prepare Read of @($startaddress -40001) bytes" 
    [byte[]]$recbuffer = new-object System.Byte[] ([int]($bytecount+9))  # +8 für ModbusTCP Header
    #write-host "prtg-pluggit: Reading socket" 
    $receivedbytes = $netStream.Read($recbuffer, 0, [int]($bytecount+9));
    #write-host "prtg-pluggit: Received Byes: $receivedbytes "
    $tcpclient.Close() 
    $netStream.Close() 
    $resultdata = $recbuffer[9..($recbuffer[8]+8)]

    if (($flipoption.tolower() -eq "reverse") -or ($flipoption.tolower() -eq "both")) {
        [array]::reverse($resultdata)
    }
    if (($resultdata.length%2 -eq 0)  `
        -and (($flipoption.tolower() -eq "flip")  `
            -or ($flipoption.tolower() -eq "both"))) {
        $resultdataflip = $resultdata.clone()
        # flip bytes für some actions
        for ($count=0; $count -lt $resultdata.length ;$count+=2) {
            $resultdataflip[$count] = $resultdata[$count+1]
            $resultdataflip[$count+1] = $resultdata[$count]
        }
        $resultdata = $resultdataflip
    }
    #write-host "  Convertto" $targetformat.tolower()
    switch ($targetformat.tolower()) {
        "uint16"    {[bitconverter]::ToUInt16($resultdata,0)}
        "int16"        {[bitconverter]::ToInt16($resultdata,0)}
        "uint32"    {[bitconverter]::ToUInt32($resultdata,0)}
        "int32"        {[bitconverter]::ToInt32($resultdata,0)}
        "uint64"    {[bitconverter]::ToUInt64($resultdata,0)}
        "int64"        {[bitconverter]::ToInt64($resultdata,0)}
        "float"        {[Math]::Round(([BitConverter]::ToSingle(($resultdata[1],$resultdata[0],$resultdata[3],$resultdata[2]),0)),1)}
        "float2"    {[Math]::Round(([BitConverter]::ToSingle($resultdataflip,0)),1)}
        "time"      {(get-date "1970-01-01 00:00:00").addseconds([bitconverter]::ToUInt32($resultdata,0))}
        "string"    {[System.Text.Encoding]::ASCII.GetString($resultdata)}
        default {$resultdata}
    }
}



write-host "Pluggit Werte: Start Script" 

write-host "#################################"
write-host "Aussenluft: " (modbusread $remoteHost $port 40133 4 float) "°C"
write-host "Zuluft Raum: " (modbusread $remoteHost $port 40135 4 float) "°C"
write-host "Abluft Raum: " (modbusread $remoteHost $port 40137 4 float) "°C"
write-host "Fortluft nach aussen: " (modbusread $remoteHost $port 40139 4 float) "°C"
write-host "Lüfterstufe: " (modbusread $remoteHost $port 40325 4 uint32 flip)
write-host "Fan1 RPM: " (modbusread $remoteHost $port 40101 4 float)
write-host "Fan2 RPM: " (modbusread $remoteHost $port 40103 4 float)
write-host "Modus: " (modbusread $remoteHost $port 40473 4 uint32 flip)
write-host "Filter-Tage übrig: " (modbusread $remoteHost $port 40555 4 uint32 flip) "Tage"
write-host "Letzter Alarm: " (modbusread $remoteHost $port 40517 4 uint32 flip)
write-host "#################################"


(08.05.2018, 16:03)Hammalui schrieb: Die Regelung der Lüftungsanlage selbst kannst du nur über Aktionen und Merker verwirklichen.

Meinst du damit das Setzen der Stufe in der Logik?

Hoffe ich konnte dir bei deinem Problem helfen  Smile 
Vllt. findet sich zu meinem Problem auch noch eine Lösung ohne die Außentemperatur der Gekko generell auf die Pluggit als Quelle umzustellen (Nachteil: Wenn die Pluggit die Temperatur misst, ist diese ja bereits erwärmt und bei ausgeschalteter Anlage stellt die Temperatur ja die Temperatur des Kellerraums dar)

Grüße
Alkahna
  • myGEKKO Slide V4725-02
  • 1x RIO 16
  • Pluggit Avent P310
#8
Hallo Alkahna, ich möchte in den Einstellungen der Lüftungsanlage erstmal nichts verändern. Wegen Gewährleistung etc.


EDIT:

(09.05.2018, 09:33)Bluescreen schrieb: Wäre einen Versuch wert, allerdings sollte man die Lüftungsanlage ja nicht unbedingt komplett abschalten...

Das stimmt wohl, habe ich auch irgendwo gehört. Also scheint die Idee mit der "Endlosschleife" eine gute Alternative zu sein (alle 60 Min kurz auf 1 anschalten und dann direkt wieder auf 0)
Wobei hier ja fast der gleiche Effekt erzielt wird mit der Ausnahme, dass die Ventilatoren mal kurz anlaufen.

Weiß jemand warum genau man die Anlange nicht komplett abschalten soll??


Ich habe gestern mit Pluggit telefoniert. Der Support meinte, dass diese Einstellung der Sicherheit dient. Es geht dabei um die Feuchte im Haus und eventuell daraus resultierender Schimmelbefall. Sollte Schimmelbefall eintreten, hätten die wohl die Möglichkeit, den Betriebsstunden-Zähler auszulesen. Dann sehen die, dass z.B. den ganzen Tag die Lüftung ausgeschaltet war.





(09.05.2018, 10:19)Alkahna schrieb:
(08.05.2018, 16:03)Hammalui schrieb: [quote='Hammalui' pid='2407' dateline='1525788212']

Die Regelung der Lüftungsanlage selbst kannst du nur über Aktionen und Merker verwirklichen.

Meinst du damit das Setzen der Stufe in der Logik?

Hoffe ich konnte dir bei deinem Problem helfen  Smile 
Vllt. findet sich zu meinem Problem auch noch eine Lösung ohne die Außentemperatur der Gekko generell auf die Pluggit als Quelle umzustellen (Nachteil: Wenn die Pluggit die Temperatur misst, ist diese ja bereits erwärmt und bei ausgeschalteter Anlage stellt die Temperatur ja die Temperatur des Kellerraums dar)

Grüße
Alkahna

Bei mir funktioniert das mit dem direkten Schalten in den Logiken nicht. Ich gebe einen digitalen Merker (z.B. M100) als Ausgabe in der Logik. In der erstellten Aktion kommt derselbe Merker als "Taster (Start)" rein. So klappt das bei mir immer.
Gruß Hammalui

EFH (BJ 2017) - MyGEKKO Slide 2 - 1 RIO37 plus 3 RIO16 - Raffstoren über SMI - Raumbus mit Einzelraumregelung - Lüftungsanlage von Pluggit - Wärmepumpe Buderus - MyGEKKO Node - Photovoltaik-Anlage 9,6 kWp plus Speicher - Erweiterung zur Garage zum Schalten von Licht und Tor (in Arbeit)
#9
(09.05.2018, 12:31)Hammalui schrieb: Hallo Alkahna, ich möchte in den Einstellungen der Lüftungsanlage erstmal nichts verändern. Wegen Gewährleistung etc.

Kann ich gut nachvollziehen, ist ja auch eher die "Hardcore"-Lösung  Angel .

(09.05.2018, 12:31)Hammalui schrieb: Ich habe gestern mit Pluggit telefoniert. Der Support meinte, dass diese Einstellung der Sicherheit dient. Es geht dabei um die Feuchte im Haus und eventuell daraus resultierender Schimmelbefall. Sollte Schimmelbefall eintreten, hätten die wohl die Möglichkeit, den Betriebsstunden-Zähler auszulesen. Dann sehen die, dass z.B. den ganzen Tag die Lüftung ausgeschaltet war.

Ok, dann scheint das ja auch nur eine Art "Absicherung" für den Hersteller zu sein. Ist meiner Meinung nach dann aber relativ egal, da die meisten Häuser keine Lüftungsanlage haben und die regeln das ja auch (über manuelles Lüften).
Somit denke ich nicht, dass es schadet, wenn man tagsüber die Anlage aus macht wenns draußen bullert und abends zum runterkühlen wieder anschaltet. Ist ja wie bei 'normalen' Menschen die Abends lüften.
Aber klar, ich kann nachvollziehen das die sich absichern wollen und warum manch einer dann lieber dem folgt was der Hersteller sagt.

Solange man die nicht 4 Wochen am Stück aus lässt wenn man in Urlaub fährt ist man glaube ich auf der sicheren Seite.
Schimmel bildet sich ja im Normalfall nicht wenn die z.b. von  9h - 21h aus ist und von 21h - 9h läuft. Und falls doch läuft irgendwas anderes gehörig schief würd ich behaupten^^

Dann ist die Sache mit der "Endlosschleife" aber genau das gleiche und genau so "schlimm" würde ich behaupten also bleibe ich bei der einfacheren Lösung indem ich einen Wert änder und keine Endlosschleife programmieren muss.
Es hätte ja auch sein können das mechanisch oder sonst was mit der Anlage passiert wenn die mal für mehrere Stunde nicht läuft. Aber das hab ich eh für unwahrscheinlich gehalten.

(09.05.2018, 12:31)Hammalui schrieb: Bei mir funktioniert das mit dem direkten Schalten in den Logiken nicht. Ich gebe einen digitalen Merker (z.B. M100) als Ausgabe in der Logik. In der erstellten Aktion kommt derselbe Merker als "Taster (Start)" rein. So klappt das bei mir immer.

Ah, jetzt hab ichs kappiert. Ja so werde ich das auch umsetzen, nachdem ich ein anderes Problem gelöst habe (anderer Thread).

EDIT: Siehe Original-Post für meine Lösung des Problems

Grüße
Alkahna
  • myGEKKO Slide V4725-02
  • 1x RIO 16
  • Pluggit Avent P310


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Steckdosen schalten mit Logik Klaus N. 0 241 17.10.2019, 20:35
Letzter Beitrag: Klaus N.
  Logik für's Badezimmerlict MrMBM 2 764 29.07.2019, 18:31
Letzter Beitrag: MrMBM
  [GELÖST] Problem mit Logik (Temp1 > Temp2 -> Gatter setzen) Alkahna 5 2.404 09.05.2018, 16:43
Letzter Beitrag: Hammalui

Gehe zu:


Benutzer, die gerade dieses Thema anschauen:
1 Gast/Gäste