Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Solaredge / Batterie einbinden
#1
Hallo,

vielleicht kann mir hier jemand weiterhelfen - der Support hat mir dazu geraten...


Wir haben eine PV Anlage mit 2 Konvertern und einem Batterie-Speicher. 
Ein Konverter konnte über SunSpec Modbus eingebunden werden (PV Produktionszähler), das funktioniert jetzt auch.

Das Problem ist das Speichersystem, welches ich beim Gekko nicht installiert bekomme -Im Solaredge Portal wird alles richtig angezeigt.



Habe es nun mit der Option Speichersystem "Individuell" versucht, - Http Station eingerichtet dazu IoStation Http/WebApi gewählt und dort den Api-Code von Solaredge eingegeben.
(Im Browser wird auch eine XML mit nachfolgenden Werten ausgegeben)

Leider wird aber im Gekko keinerlei Batteriestatus angezeigt (immer 0%) - was mache ich hier falsch?
Danke für Euere Tipps!

Hier die XML-Ausgabe:

<siteCurrentPowerFlow>
<updateRefreshRate>3</updateRefreshRate>
<unit>kW</unit>
<GRID>
<status>Active</status>
<currentPower>0.7</currentPower>
</GRID>
<LOAD>
<status>Active</status>
<currentPower>0.7</currentPower>
</LOAD>
<PV>
<status>Idle</status>
<currentPower>0.0</currentPower>
</PV>
<STORAGE>
<status>Idle</status>
<currentPower>0.0</currentPower>
<chargeLevel>11</chargeLevel>
<critical>false</critical>
</STORAGE>
<connections>
<connection>
<from>GRID</from>
<to>Load</to>
</connection>
</connections>

</siteCurrentPowerFlow>

my Gekko
#2
Hallo el-Rubio,

ich konnte meine 2 Wechselrichter (WR) nur über die API Schnittstelle einrichten. Wie ich das gemacht habe, kannst du dir im folgenden Thread anschauen:

https://forum.my-gekko.com/showthread.ph...16#pid4116

Kriegst du überhaupt keine Daten über API raus oder fehlt nur der Speicherstatus. Bei mir hat es Wochen gedauert, ehe ich die richtigen Werte von der API gefunden habe.

Welche WR und welche Batterie hast du eigentlich? Also welcher Hersteller, Typ etc.
Gruß Hammalui

EFH (BJ 2017) - MyGEKKO Slide 2 - 1 RIO37 plus 3 RIO16 - Raffstoren über SMI - Raumbus mit Einzelraumregelung - Lüftungsanlage von Pluggit - Wärmepumpe Buderus - MyGEKKO Node - Photovoltaik-Anlage 9,6 kWp plus Speicher - Erweiterung zur Garage zum Schalten von Licht und Tor (in Arbeit)
#3
Hallo,


habe auch die Solaredge API integriert, jedoch habe ich keinen Speicher und kann dir daher nicht mit Sicherheit sagen ob das so stimmt, aber ich denke es müsste wie folgt funktionieren:


In der HTTP Station bei Request ON die URL eingeben die du im Browser eingegeben hast um auf die oben gepostete XML zu gelangen.

Bei Request OFF/Parameter gibts du folgendes ein: JSON@siteCurrentPowerFlow.storage.chargelevel


Hoffe es klappt!

Grüße
Daniel
#4
Hallo vielen Dank für Eure Hilfe,

nachdem ich bei bei Request OFF/ den Parameter " JSON@siteCurrentPowerFlow.storage.chargelevel " eingegeben habe, ändert sich zumindest die Batterieanzeige.

Gestern Abend korrekt auf Restladung 10%, heute bleibt sie aber bei 11% stehen, wohingegen das Solaredge Portal andere Werte anzeigt!

Die Batterie ist übrigens von LG


Angehängte Dateien Thumbnail(s)
       
#5
So, komisch - jetzt hat sich der Batteriestand dem Solaredge-Portal angeglichen und ist identisch, scheint jetzt also doch zu funktionieren.

Lediglich der Punkt "Tag Ladung" ist  wohl nicht korrekt - das ist immer der gleiche Wert wie rechts unten (Netzbezug)


Angehängte Dateien
.jpg   gekko-ladung.jpg (Größe: 29,84 KB / Downloads: 89)
#6
Hallo,

Ich vermute mal dass du die maximalen requests erreicht hast.
Die solaredge API erlaubt nur 300 requests pro Tag.
Das ist ungefähr ein request alle 5 Minuten.
Du musst also die request time auf 300 Sekunden stellen dann sollte es passen.

Grüße
Daniel
#7
Hallo,

ja - so war es wohl - danke für Deine Tipps!
Da wäre ich sonst nicht mehr weiter gekommen!
#8
Hallo,

freut mich wenn es klappt!

Kein Problem, das Forum ist doch da um sich gegenseitig zu unterstützen.

Grüße
Daniel
#9
Hallo Daniel,

kannst du mir erklären wie du die API von Solaredge in Mygekko eingebunden hast?

Das habe ich schon probiert:

In der HTTP Station bei Request ON die URL eingeben die du im Browser eingegeben hast um auf die oben gepostete XML zu gelangen.

Bekomme aber im Gekko nichts angezeigt.

Die Produktion bekomme ich über LAN Modbus aber mir fehlen die anderen Werte.

Diese würde ich gerne über API abrufen.

Vielen Dank!
8 Rollos Vestamatic SMI, 3 Lichtkreise, Shelly 2.5 Gäste WC Rollo, Hue Bridge  + 2 Deckenlampen im Einsatz, Ha Bridge für Rollos und Lichtkreise + Alexa Anbindung Vorhanden und erfolgreich im Einsatz. Sonoff RF Bridge + Tasmota im Test für Baummarkt Schaltersteckdosen..Verzweiflung.


Gehe zu:


Benutzer, die gerade dieses Thema anschauen:
1 Gast/Gäste